Cómo te afecta la vulnerabilidad kr00k de los chips wifi y cómo puedes evitarla


Una nueva vulnerabilidad crítica afecta a los chips wifi. Se trata de kr00k, identificada como CVE-2019-15126, un fallo que ha puesto en riesgo las comunicaciones de innumerables dispositivos en todo el mundo, desde ordenadores a móviles pasando por televisores o maquinarias.


Esta preocupante vulnerabilidad, desvelada por ESET, afectaría a nada menos que mil millones de equipos y compromete los paquetes de red exponiéndolosa posibles ataques por una generación de claves de cifrado erróneas.

ESET cifra en 1.000 millones los equipos afectados por la vulnerabilidad kr00k

Concretamente, los dispositivos afectados son aquellos que utilizan chips de Broadcom y Cypress. Dispositivos de compañías tan populares como Google, Samsung o Apple emplean los componentes de estas empresas.


Cómo te afecta la vulnerabilidad kr00k

La vulnerabilidad kr00k afecta particularmente a las conexiones inalámbricas wifi que utilizan los protocolos de seguridad WPA2-Personal o WPA2-Enterprise WiFi con encriptación AES-CCMP. Hablamos, como decíamos antes, de afectaciones en dispositivos populares de marcas comunes.


Por ejemplo, el Samsung Galaxy S8, el Amazon Kindle 8ª gen, el Apple iPad mini 2, el Google Nexus 6, la Raspberry Pi 3 o los Apple iPhone 6, 6S, 8 y XR. Dispositivos con unos cuantos años que, sin embargo, siguen utilizándose. Aunque no hay que olvidar que también se encuentran afectados módems wifi.

Esta vulnerabilidad puede ser explotada para interceptar y descifrar el tráfico que pasa por el chip wifi de los dispositivos afectados

Este fallo de seguridad afecta al cifrado que se emplea para proteger los paquetes de datos que se envían a través de la conexión wifi y puede ser explotado para interceptar y descifrar ese tráfico. Es decir, un potencial atacante podría ver la información que llega o se envía desde dispositivos afectados.


No obstante, cabe destacar que hablamos de una afectación concreta del cifrado del chip wifi, lo que no significa que el cifrado efectuados por una conexiones segura mediante el protocolo HTTPS, por ejemplo, se encuentre afectado.

Cómo puedes evitar la vulnerabilidad kr00k

La forma de evitar la vulnerabilidad kr00k, oficialmente identificada como CVE-2019-15126, pasa por actualizar los dispositivos afectados o asegurarnos de que las últimas actualizaciones aplicadas a los mismos parchean el problema.

La mayoría de los principales fabricantes de dispositivos que se han visto afectados al usar los chips problemáticos han lanzado actualizaciones, ha asegurado ESET, y han trabajado a lo largo de los últimos meses junto a los investigadores en ciberseguridad para atajar las potenciales amenazas.

Debemos actualizar el sistema operativo, el software o el firmware, lo que corresponda según el tipo de dispositivo, asegurándonos de que se instala el parche que soluciona el fallo

Las actualizaciones deberíamos aplicarlas a todos los dispositivos que potencialmente puedan verse afectados por kr00k, si no se han aplicado ya. Y, dependiendo del tipo de aparato, hablamos de actualizar su sistema operativo, su software o su firmware. Con ello, nos encontraríamos protegidos.


Vía | Genbeta

En | Cómo te afecta la vulnerabilidad kr00k de los chips wifi y cómo puedes evitarla

Escrito por | TONI CASTILLO

Entradas Recientes

Ver todo

developWorldNews

© 2019 developWorld es una marca propiedad de develop talent & tecnology

Sitio diseñado por: 

Sr. Zorro Estudio de Diseño

Calle Puebla 46 Col. Roma Norte, CDMX, México

  • Facebook - círculo blanco